Category Archives: Debian

Install Eclipse and RadRails

Background OS: Debian 8 JDK 1.8 already installed Install Eclipse Eclipse can be installed using apt-get (Resources 1) > sudo apt-get install eclipse eclipse-jdt eclipse-cdt Parameters are list of packages installed eclipse – Extensible tool platform and Java IDE eclipse-jdt – Eclipse Java development tools (JDT) eclipse-cdt – C/C++ development tools for Eclipse IDE The… Read More »

Install PostgreSQL Database Driver

Background OS: Debian 8 PostgreSQL, Ruby and Rails installed Part of efforts to write a small Ruby on Rails reporting application which requires connection to PostgreSQL database. Attempt to install PostgreSQL database driver and got “missing library” error. > gem install postgresql Building native extensions. This could take a while… ERROR: Error installing postgresql: ERROR:… Read More »

First attempt to run rails server and got “error while trying to load the gem ‘uglifier'”

Background OS: Debian 8 Ruby version: ruby 2.1.5p273 (2014-11-13) [i386-linux-gnu] Rails version: Rails 4.2.5 Ruby and Rails are installed, created first hello world app, executed “bundle install” Trying to run “rails server” > rails server Warning: Running `gem pristine –all` to regenerate your installed gemspecs (and deleting then reinstalling your bundle if you use bundle… Read More »

First attempt to run bundle install and got “Could not find bundler” error

Background OS: Debian 8 Ruby version: ruby 2.1.5p273 (2014-11-13) [i386-linux-gnu] Rails version: Rails 4.2.5 Ruby and Rails are installed and created first hello world app Trying to run “bundle install” > bundle install /usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs’: Could not find ‘bundler’ (>= 0) among 66 total gem(s) (Gem::LoadError) from /usr/lib/ruby/2.1.0/rubygems/dependency.rb:309:in `to_spec’ from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:53:in `gem’ from /usr/local/bin/bundle:22:in `’… Read More »

Create Rails Hello World and got “sqlite3.h is missing” error

Background OS: Debian 8 Ruby version: ruby 2.1.5p273 (2014-11-13) [i386-linux-gnu] Rails version: Rails 4.2.5 Ruby and Rails are installed and trying to create the first application. > rails new hello_app … Installing sqlite3 1.3.11 with native extensions Gem::Ext::BuildError: ERROR: Failed to build gem native extension.     /usr/bin/ruby2.1 extconf.rb checking for sqlite3.h… no sqlite3.h is missing.… Read More »